Bug #82539

Broken installation due to multiple TCA initalization

Added by Nicole Cordes 11 months ago. Updated 11 months ago.

Status:
Resolved
Priority:
Should have
Assignee:
Category:
-
Target version:
Start date:
2017-09-21
Due date:
% Done:

100%

TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

Given:

A TYPO3 CMS 8 installation with activated EXT:ods_redirects (https://extensions.typo3.org/extension/ods_redirects/)

Expected:

A configured redirect is executed properly.

Actual:

A PHP error "Argument 2 passed to TYPO3\CMS\Core\Utility\GeneralUtility::setSingletonInstance() must implement interface TYPO3\CMS\Core\SingletonInterface, boolean given" is thrown.

Associated revisions

Revision a398a717 (diff)
Added by Nicole Cordes 11 months ago

[BUGFIX] Allow multiple calls of ExtensionManagementUtility::loadBaseTca

Although the function itself is marked as private, it can be triggered
twice due to official API in EidUtility::initTCA. As requireOnce returns
true if called multiple times with the same file, this return state has
to be handled as well.

Resolves: #82539
Related: #82408
Releases: 8.7
Change-Id: I1acd519c342e525c06eda44289acdf86c508a898
Reviewed-on: https://review.typo3.org/54201
Tested-by: TYPO3com <>
Reviewed-by: Oliver Hader <>
Reviewed-by: Faton Haliti <>
Tested-by: Faton Haliti <>
Reviewed-by: Wouter Wolters <>
Reviewed-by: Helmut Hummel <>
Tested-by: Helmut Hummel <>

History

#1 Updated by Nicole Cordes 11 months ago

Also the patch was merged to master, due to TCA loading only 8.7 is affected by the regression.

#2 Updated by Gerrit Code Review 11 months ago

  • Status changed from New to Under Review

Patch set 1 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/54201

#3 Updated by Nicole Cordes 11 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF