Bug #82757

Livesearch overlay broken

Added by Markus Sommer over 1 year ago. Updated 8 months ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
Backend User Interface
Start date:
2017-10-13
Due date:
% Done:

100%

TYPO3 Version:
9
PHP Version:
7.0
Tags:
CSS, Javascript
Complexity:
easy
Is Regression:
Sprint Focus:

Description

Expected Behavior

As Backenduser i wand to see an overlay with informations when i type into the livesearch

Actual Behavior

The livesearch overlay is brocken if the first result is empty

Steps to Reproduce the Problem

  • Login into TYPO3
  • Klick into the Livesearch
  • Type a non matching term like (qwertzopĆ¼)

Specifications

  • Version: 9-dev (cc2bd063b7 [master])
  • Platform: MacOs
  • Subsystem: Chrome 63 and Firefox 57

screenshot.png View (27 KB) Markus Sommer, 2017-10-13 13:49

Associated revisions

Revision 69011004 (diff)
Added by Andreas Fernandez over 1 year ago

[BUGFIX] Remove style attribute in LiveSearch

Currently, `beforeRender` removes some inline CSS so adjust the layout
of the suggest list. If the first search has no result, the layout is
broken because `beforeRender` is not called in case there are no results.

This patch removes the style attribute as early as possible.

Resolves: #82757
Releases: master, 8.7
Change-Id: I844b81aca43bd469dfdbb46516366f4786d0935f
Reviewed-on: https://review.typo3.org/54439
Reviewed-by: Mathias Schreiber <>
Tested-by: Mathias Schreiber <>
Tested-by: TYPO3com <>
Reviewed-by: Wouter Wolters <>
Tested-by: Wouter Wolters <>

Revision b0d9f03b (diff)
Added by Andreas Fernandez over 1 year ago

[BUGFIX] Remove style attribute in LiveSearch

Currently, `beforeRender` removes some inline CSS so adjust the layout
of the suggest list. If the first search has no result, the layout is
broken because `beforeRender` is not called in case there are no results.

This patch removes the style attribute as early as possible.

Resolves: #82757
Releases: master, 8.7
Change-Id: I844b81aca43bd469dfdbb46516366f4786d0935f
Reviewed-on: https://review.typo3.org/54440
Tested-by: TYPO3com <>
Reviewed-by: Wouter Wolters <>
Tested-by: Wouter Wolters <>

History

#1 Updated by Gerrit Code Review over 1 year ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/54439

#2 Updated by Gerrit Code Review over 1 year ago

Patch set 1 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/54440

#3 Updated by Andreas Fernandez over 1 year ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#4 Updated by Benni Mack 8 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF