Bug #83035

possibly dupe with #65234 but still not working - UL > P > LI

Added by Florian Harms over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
Could have
Assignee:
-
Category:
-
Target version:
-
Start date:
2017-11-19
Due date:
2017-11-22
% Done:

100%

TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Folks,
with current version TYPO3 8.7.8, the ckeditor still delivers a construction
<UL>
<P></P>
<LI> ... </LI>
<P></P>
...
</UL>

Well, nobody knows why there is an extra paragraph structure in that one (it doesn't make sense at all). I have followed the different tips from other forges but didn't get rid of those extra paragraphs, and indeed the EXT:fluid_styled_content/Configuration/TypoScript/Helper/ParseFunc.txt seems to have a function not to set in those P's. But they aren't working.

Is there any chance to get rid of those P's? And best: WITHOUT hacking the whole setup on the root level... :)

BTW: Installed is TYPO3 8.7.8, fluid_styled_content and its CSS.

Thanks for any tip.

Florian

2017-11-19 20_54_10-vateud.net [TYPO3 CMS 8.7.8].png View (68 KB) Florian Harms, 2017-11-19 20:56

History

#1 Updated by Chris topher over 1 year ago

  • Project changed from forge.typo3.org to TYPO3 Core
  • TYPO3 Version set to 8

#2 Updated by Frans Saris over 1 year ago

Are you using a clean/fresh install or are there any special extensions etc?

Can you show us your pageTS especially RTE.proc.
Maybe create a screenshot of the BE info module.

And can you check what is saved in the database.

Looks like you have some old (pre TYPO3 8.7) RTE.proc that is the cause of this issue.

#3 Updated by Frans Saris over 1 year ago

  • Status changed from New to Needs Feedback

#4 Updated by Florian Harms over 1 year ago

Frans,
cheers for looking into this.

Well, the current active standard is like this (landing page ts):

TCAdefaults.pages.url_scheme = 2
TCEFORM.pages.layout {
addItems {
4 = Landing page design
}
altLabels {
0 = Article-setup
1 = News Setup
2 = VACC countries
3 = Special pages
}
}

So, nothing special i think. The different layouts of course are covered by the template to setup the looks.

I have tried those sets:

lib.parseFunc_RTE {
externalBlocks {
ol {
stripNL = 1
stdWrap.parseFunc = < lib.parseFunc
}
ul {
stripNL = 1
stdWrap.parseFunc = < lib.parseFunc
}
}
}

lib.parseFunc_RTE {
externalBlocks := addToList(ul)
externalBlocks {
ul.stripNL = 1
ul.callRecursive = 1
ul.callRecursive.tagStdWrap.HTMLparser = 1
ul.callRecursive.tagStdWrap.HTMLparser.tags.ul {
fixAttrib.class.default = contentList
}
}
}

And they didn't have impact on the problem. Unfortunately. BTW. here is a link to the page i am currently building: http://prod.vateud.net/index.php?id=11

Snapshot is amended.

And again: thanks for helping to identify it.

Florian

#5 Updated by Frans Saris over 1 year ago

I'm interested in the full pagets have a look at the BE info module. There you can view the complete composed pagets like it is used.

#6 Updated by Florian Harms over 1 year ago

Frans Saris wrote:

I'm interested in the full pagets have a look at the BE info module. There you can view the complete composed pagets like it is used.

Oh no problem, more than welcomed. How can we come together? Could you send me a mail for giving you credentials or a Teamwiever look?

Florian

#7 Updated by Florian Harms over 1 year ago

Frans Saris wrote:

Are you using a clean/fresh install or are there any special extensions etc?

Can you show us your pageTS especially RTE.proc.
Maybe create a screenshot of the BE info module.

And can you check what is saved in the database.

Looks like you have some old (pre TYPO3 8.7) RTE.proc that is the cause of this issue.

And yes, this is a clean install on a new box... installed last Tuesday. Looking for the RTE.proc

#8 Updated by Florian Harms over 1 year ago

  • Due date set to 2017-11-22
  • Priority changed from Should have to -- undefined --
  • % Done changed from 0 to 100

Florian Harms wrote:

Frans Saris wrote:

Are you using a clean/fresh install or are there any special extensions etc?

Can you show us your pageTS especially RTE.proc.
Maybe create a screenshot of the BE info module.

And can you check what is saved in the database.

Looks like you have some old (pre TYPO3 8.7) RTE.proc that is the cause of this issue.

And yes, this is a clean install on a new box... installed last Tuesday. Looking for the RTE.proc

Good afternoon again...

Mission accomplished. It was a typoscript thingy i have created myself. So, no worries to the setup.

I was simply checking a bit and found out that the OL tag was not creating the additional <P>. Therefore I have created a very basic ts template and the UL, LI part was working absolutely correct. The error was self made in the RTE configuration typoscript to add a few more switches for the editors fun. And one added the extra line.

As we all know: "Ignorance is the mother of all adventures"... :)

Thanks again for your great work.

Florian

#9 Updated by Frans Saris over 1 year ago

  • Status changed from Needs Feedback to Closed
  • Priority changed from -- undefined -- to Could have

Good to hear the issue is resolved

Also available in: Atom PDF