Bug #84233

Type BIT not supported by Typo3/Doctrine DBAL (working with alternative DB)

Added by Florian Rival over 2 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Database API (Doctrine DBAL)
Target version:
-
Start date:
2018-03-13
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Hi,

When using the Typo3 API with an alternative database, a table contains a column with type BIT but this type is not supported by Typo3/Doctrine DBAL, it results with the following message (see attachement) :

Unknown database type bit requested, Doctrine\DBAL\Platforms\MySQL57Platform may not support it. 

While Doctrine/DBAL allowed to add custom data type, I didn't find a way with Typo3 (hook, config file) to add a custom datatype.

It should be possible with Typo3 to add a custom data type and may be better, Typo3 should have BIT type as a native type.

Florian


Files

Type BIT not supported.png (177 KB) Type BIT not supported.png Florian Rival, 2018-03-13 10:19

Related issues

Is duplicate of TYPO3 Core - Bug #83779: Doctrine Exception prevents to enable ExtensionsNeeds Feedback2018-02-05

Actions
#1

Updated by Georg Ringer over 2 years ago

  • Is duplicate of Bug #83779: Doctrine Exception prevents to enable Extensions added
#2

Updated by Georg Ringer over 2 years ago

  • Status changed from New to Closed

closed as duplicate of #83779

Also available in: Atom PDF