Bug #84702

E-Mail link parameter encoded incorrectly for encryption

Added by Jan Delius almost 2 years ago. Updated 4 days ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2018-04-12
Due date:
% Done:

0%

TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

If a TYPO3 page uses the configuration spamProtectEmailAddresses with a mailto link that contains a predefined subject with a encoded space(%20), the link generated by javascript after decryption contains incorrect characters.

For example:

mailto: ?subject=My%20subject

After decrypt with javascript: ?subject=My0subject

History

#1 Updated by Gerrit Code Review almost 2 years ago

  • Status changed from New to Under Review

Patch set 1 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/56639

#2 Updated by Susanne Moog 4 days ago

  • Status changed from Under Review to Closed

Cannot reproduce the issue with latest TYPO3 versions. The example in the description works fine for me. Please reopen issue if necessary.

Also available in: Atom PDF