Bug #84785

Execution order of hooks ['tslib/index_ts.php']['preprocessRequest'] and ['tslib/class.tslib_fe.php']['pageIndexing'] changed from 8.7 to 9.2

Added by Timo Hund over 1 year ago. Updated 11 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Frontend
Target version:
Start date:
2018-04-18
Due date:
% Done:

100%

TYPO3 Version:
9
PHP Version:
7.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Between 8 LTS and 9.2 the order of the execution of the following hooks was changed:

8.7

- First: $GLOBALS['TYPO3_CONF_VARS']['SC_OPTIONS']['tslib/index_ts.php']['preprocessRequest']
- Second: $GLOBALS['TYPO3_CONF_VARS']['SC_OPTIONS']['tslib/class.tslib_fe.php']['pageIndexing']

9.2

- First: $GLOBALS['TYPO3_CONF_VARS']['SC_OPTIONS']['tslib/class.tslib_fe.php']['pageIndexing']
- Second: $GLOBALS['TYPO3_CONF_VARS']['SC_OPTIONS']['tslib/index_ts.php']['preprocessRequest']

I could fix that by changing the order of the RequestMiddlewares in (sysext/frontend/Configuration/RequestMiddlewares.php)

from


'typo3/cms-frontend/tsfe' => [
    
  'target' => \TYPO3\CMS\Frontend\Middleware\TypoScriptFrontendInitialization::class,
    
  'after' => [
        
      'typo3/cms-core/normalized-params-attribute',
    
   ]

],



to
'typo3/cms-frontend/tsfe' => [
    
   'target' => \TYPO3\CMS\Frontend\Middleware\TypoScriptFrontendInitialization::class,
    
   'after' => [
        
      'typo3/cms-frontend/eid',

   ]

],

but since i do not know if this is intended or if this break the order for other hooks it would be nice when somebody with a deeper knowledge of TypoScriptFontendController can have a look on it

Associated revisions

Revision e45acadb (diff)
Added by Timo Hund over 1 year ago

[BUGFIX] Execution order of hooks preprocessRequest and pageIndexing changed

Between 8 LTS and 9.2 the order of the execution of the following hooks was changed:

8.7

- First: $GLOBALS['TYPO3_CONF_VARS']['SC_OPTIONS']['tslib/index_ts.php']['preprocessRequest']
- Second: $GLOBALS['TYPO3_CONF_VARS']['SC_OPTIONS']['tslib/class.tslib_fe.php']['pageIndexing']

9.2

- First: $GLOBALS['TYPO3_CONF_VARS']['SC_OPTIONS']['tslib/class.tslib_fe.php']['pageIndexing']
- Second: $GLOBALS['TYPO3_CONF_VARS']['SC_OPTIONS']['tslib/index_ts.php']['preprocessRequest']

This patch, changes the RequestMiddlewares configuration to do "typo3/cms-frontend/tsfe"
after "typo3/cms-frontend/eid"

Resolves: #84785
Releases: master
Change-Id: I215ee170774dd1b73f2e12519bc1b6ccf557e361
Reviewed-on: https://review.typo3.org/56733
Tested-by: TYPO3com <>
Reviewed-by: Kay Strobach <>
Tested-by: Kay Strobach <>
Reviewed-by: Mathias Schreiber <>
Tested-by: Mathias Schreiber <>
Reviewed-by: Benni Mack <>
Tested-by: Benni Mack <>

History

#1 Updated by Timo Hund over 1 year ago

  • Description updated (diff)

#2 Updated by Timo Hund over 1 year ago

  • Description updated (diff)

#3 Updated by Gerrit Code Review over 1 year ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/56733

#4 Updated by Timo Hund over 1 year ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#5 Updated by Benni Mack 11 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF