Bug #84786

FeLogin does not redirect to access restricted page

Added by Steffen Kamper about 1 year ago. Updated 10 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
felogin
Target version:
-
Start date:
2018-04-18
Due date:
% Done:

0%

TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

If i redirect after login to any normal page, redirect works.
If i redirect after login to any access restricted page, it does not work. URL stays on login page (even if the page is hidden after login, in this case displayed page is the first available)

I guess that the redirect is before the access check.

History

#1 Updated by Steffen Kamper about 1 year ago

hm - difficult to track down. On my local machine it works, on the live server not. Still investigating.

#2 Updated by Steffen Kamper about 1 year ago

Ok, got it:

It does not work because the login page is set to "Hide at login". So after login, the page is not available and the redirect does not work.

I needed to make a complex workaround here, anyways i think it should work though, as the redirect settings should work direct after successful login. As the code is in the plugin it can't work this way.

Any suggestions are welcome.

#3 Updated by Riccardo De Contardi about 1 year ago

  • Status changed from New to Needs Feedback

If I remember correctly this a quite old problem...see #27735 .

felogin documentation states that the login page can't be hidden :

https://docs.typo3.org/typo3cms/extensions/felogin/Examples/Index.html#access-restrictions-on-the-felogin-plugin

and suggests some solutions:

A lot of time ago (9 or 10 years maybe) I also found a workaround that involved having multiple pages, something like:

1. Page "Login" (shortcut to 2, access: hide at login)
2. Page "LoginPage" (Hidden in menu, access: standard page)
3. Page "Logout" (shortcut to 2 with &logintype=logout, access: show at login)

I don't know if it is still useful, too much time has passed since I used it the last time.

Do you mind if I close this issue? I think that the behavior is the expected one. If I have understood it wrong, please add some other details. Thank you.

#4 Updated by Riccardo De Contardi about 1 year ago

  • Category set to felogin

#5 Updated by Riccardo De Contardi 10 months ago

  • Status changed from Needs Feedback to Closed

No feedback since the last 90 days => closing this issue.

If you think that this is the wrong decision or experience the issue again and have more information about how to reproduce your problem, please reopen it or open a new issue with a reference to this one.

Thank you and best regards

Also available in: Atom PDF