Bug #84962

Enforce int type for database value

Added by Nicole Cordes about 3 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
-
Target version:
-
Start date:
2018-05-10
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Given:
- mysql database without strict_mode
- a functional test where fixtures from xml are stored in the database
- fixtures contain timestamp the are passed as string

Expected:
- \TYPO3\CMS\Extbase\DomainObject\AbstractDomainObject can be created from database fixture

Actual:
- An error occurs because a timestamp cannot be converted to a DateTime object

#1

Updated by Gerrit Code Review about 3 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/56909

#2

Updated by Gerrit Code Review about 3 years ago

Patch set 1 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/56914

#3

Updated by Nicole Cordes about 3 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#4

Updated by Gerrit Code Review about 3 years ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch TYPO3_7-6 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/56915

#5

Updated by Nicole Cordes about 3 years ago

  • Status changed from Under Review to Resolved
#6

Updated by Benni Mack over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF