Bug #85182

Editing a existing link in ckeditor does not keep the CSS-Class value.

Added by Frédéric Lebel over 3 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
RTE (rtehtmlarea + ckeditor)
Target version:
-
Start date:
2018-06-08
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
8
PHP Version:
7.1
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

How to reproduce

Create a link in the ckeditor with a "bouton compact" CSS-Class.

Edit again the same link.

Then, the class name combination is not set in the modal.

Config:

Add a class name combination in the ckeditor config : Default.yml.

buttons:
link:
properties:
class:
allowedClasses: 'bouton compact,bouton compact fond-rouge,bouton compact fond-jaune,bouton compact fond-bleu,bouton bouton-tiers,bouton bouton-tiers fond-rouge,bouton bouton-tiers fond-jaune,bouton bouton-tiers fond-bleu,bouton bouton-demi,bouton bouton-demi fond-rouge,bouton bouton-demi fond-jaune,bouton bouton-demi fond-bleu,bouton pleine-largeur,bouton pleine-largeur fond-rouge,bouton pleine-largeur fond-jaune,bouton pleine-largeur fond-bleu'

Also, the code I removed seems to be dead code from rtehtmlarea.

Thanks for reading.


Files

patch.diff (1.04 KB) patch.diff Frédéric Lebel, 2018-06-08 05:14
#1

Updated by Gerrit Code Review over 3 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/57387

#2

Updated by Gerrit Code Review over 3 years ago

Patch set 1 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/57439

#3

Updated by Frédéric Lebel over 3 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#4

Updated by Benni Mack over 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF