Bug #85586

translateElementError-ViewHelper does not work with TYPO3\CMS\Extbase\Error\Error

Added by Daniel Siepmann about 1 year ago. Updated 11 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Form Framework
Target version:
-
Start date:
2018-07-18
Due date:
% Done:

100%

TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Under some circumstances an TYPO3\CMS\Extbase\Error\Error is rendered instead of an TYPO3\CMS\Extbase\Validation\Error, which is extending the Error\Error.

This is not supported. There are checks for Validation\Error to retrieve the code.

These circumstances are for example:
Non complete file uploads, e.g. to server settings and file size.
Non allowed mime type.

Associated revisions

Revision 8c4abd65 (diff)
Added by Daniel Siepmann about 1 year ago

[BUGFIX] Allow Error\Error to be translated in form extension

Some errors added while processing forms are of Type
TYPO3\CMS\Extbase\Error\Error instead of
TYPO3\CMS\Extbase\Validation\Error as they occur in different places.
E.g. the mime type check is handled inside the TypeConverter and file
uploads can be canceled due to file size.

These errors should not lead to errors when rendered in Fluid.

Resolves: #85586
Releases: master, 8.7
Change-Id: I02eafff4b7d56a661eb956ff107c0eb0476fd6a7
Reviewed-on: https://review.typo3.org/57622
Tested-by: TYPO3com <>
Reviewed-by: Daniel Goerz <>
Reviewed-by: Ralf Zimmermann <>
Tested-by: Ralf Zimmermann <>
Reviewed-by: Jörg Bösche <>
Reviewed-by: Christian Kuhn <>
Tested-by: Christian Kuhn <>

Revision 940d6153 (diff)
Added by Daniel Siepmann about 1 year ago

[BUGFIX] Allow Error\Error to be translated in form extension

Some errors added while processing forms are of Type
TYPO3\CMS\Extbase\Error\Error instead of
TYPO3\CMS\Extbase\Validation\Error as they occur in different places.
E.g. the mime type check is handled inside the TypeConverter and file
uploads can be canceled due to file size.

These errors should not lead to errors when rendered in Fluid.

Resolves: #85586
Releases: master, 8.7
Change-Id: I02eafff4b7d56a661eb956ff107c0eb0476fd6a7
Reviewed-on: https://review.typo3.org/57742
Tested-by: TYPO3com <>
Reviewed-by: Christian Kuhn <>
Tested-by: Christian Kuhn <>

History

#1 Updated by Daniel Siepmann about 1 year ago

The error was introduced in https://github.com/TYPO3/TYPO3.CMS/commit/70b8ffc06c68a21a5dc191d6b7f77b42092fc208 where Validation\Error is checked instead of Error\Error.

#2 Updated by Daniel Siepmann about 1 year ago

  • Category set to Form Framework

#3 Updated by Gerrit Code Review about 1 year ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/57622

#4 Updated by Gerrit Code Review about 1 year ago

Patch set 1 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/57742

#5 Updated by Daniel Siepmann about 1 year ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#6 Updated by Benni Mack 11 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF