Bug #85907

Regression in latest version 8 - class Environment used but does not exists

Added by Steffen Kamper 9 months ago. Updated 9 months ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
-
Target version:
-
Start date:
2017-04-21
Due date:
2017-04-21
% Done:

0%

TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Just open a CE with Image, you will get this error:
Class 'TYPO3\CMS\Core\Utility\Environment' not found

The cause is this commit:
https://git.typo3.org/Packages/TYPO3.CMS.git/commit/a4340b6c03fd416e8ca2ac2f59e8582a102fcb8c
(thanks Benny for the finding)


Related issues

Duplicates TYPO3 Core - Bug #85908: Fatal error "class TYPO3\CMS\Core\Utility\Environment not found Closed 2018-08-20
Follows TYPO3 Core - Bug #80909: Detection of current ImageMagick Version 7 Closed 2017-04-20

History

#1 Updated by Steffen Kamper 9 months ago

  • Subject changed from Regression in latest version 8 - class Environment used nut does not eists to Regression in latest version 8 - class Environment used but does not eists

#2 Updated by Steffen Kamper 9 months ago

  • Subject changed from Regression in latest version 8 - class Environment used but does not eists to Regression in latest version 8 - class Environment used but does not exists

#3 Updated by Stephan Großberndt 9 months ago

  • Due date set to 2017-04-21
  • Start date changed from 2018-08-20 to 2017-04-21
  • Follows Bug #80909: Detection of current ImageMagick Version 7 added

#4 Updated by Stephan Großberndt 9 months ago

  • Duplicates Bug #85908: Fatal error "class TYPO3\CMS\Core\Utility\Environment not found added

#5 Updated by Stephan Großberndt 9 months ago

  • Status changed from New to Closed

Also available in: Atom PDF