Bug #85908

Fatal error "class TYPO3\CMS\Core\Utility\Environment not found

Added by Oliver Hader about 1 year ago. Updated about 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
Start date:
2018-08-20
Due date:
% Done:

100%

TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

Fatal error "Class TYPO3\CMS\Core\Utility\Environment not found in TYPO3\CMS\Core\Utility\CommandUtility"


Related issues

Related to TYPO3 Core - Bug #80909: Detection of current ImageMagick Version 7 Closed 2017-04-20
Duplicated by TYPO3 Core - Bug #85907: Regression in latest version 8 - class Environment used but does not exists Closed 2017-04-21 2017-04-21

Associated revisions

Revision f524f227 (diff)
Added by Jigal van Hemert about 1 year ago

Revert "[BUGFIX] Detect current ImageMagick Version 7 for Windows."

This reverts commit a4340b6c03fd416e8ca2ac2f59e8582a102fcb8c.

Due to the PHP fatal error in TYPO3\CMS\Core\Utility\CommandUtility
"Class TYPO3\CMS\Core\Utility\Environment", the change gets reverted.
TYPO3\CMS\Core\Utility\Environment was first introduced in TYPO3 v9
and thus does not exist in TYPO3 v8.

Resolves: #85908
Related: #80909
Change-Id: I2eba784e0a6fd83d1d9a70db7b57c89c54d29f55
Reviewed-on: https://review.typo3.org/57966
Reviewed-by: Riny van Tiggelen <>
Reviewed-by: Andreas Fernandez <>
Reviewed-by: Steffen Kamper <>
Tested-by: Steffen Kamper <>
Reviewed-by: Oliver Hader <>
Tested-by: Oliver Hader <>

History

#1 Updated by Oliver Hader about 1 year ago

  • Related to Bug #80909: Detection of current ImageMagick Version 7 added

#2 Updated by Gerrit Code Review about 1 year ago

  • Status changed from New to Under Review

Patch set 2 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/57966

#3 Updated by Gerrit Code Review about 1 year ago

Patch set 3 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/57966

#4 Updated by Stephan GroƟberndt about 1 year ago

  • Duplicated by Bug #85907: Regression in latest version 8 - class Environment used but does not exists added

#5 Updated by Oliver Hader about 1 year ago

  • Is Regression set to Yes

#6 Updated by Oliver Hader about 1 year ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#7 Updated by Benni Mack about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF