Bug #86565

"Dump autoload" reports green when in composer mode

Added by Pascal Querner about 1 year ago. Updated 7 months ago.

Status:
Closed
Priority:
Could have
Assignee:
-
Category:
Install Tool
Target version:
-
Start date:
2018-10-04
Due date:
% Done:

100%

TYPO3 Version:
9
PHP Version:
7.2
Tags:
installtool 9.5-lts
Complexity:
no-brainer
Is Regression:
Sprint Focus:

Description

When in composer-mode with TYPO3 9.5 LTS trying to "dump autoload" from the Install Tool webview, the response is "Skipped generating additional class loading information in composer mode." but is reported as "green".

I suggest changing the green reponse to yellow to indicate a warning that nothing had been done, because its not possible to dump autoload with composer usage.

OR

Better yet, hide that option all togehter (as it does nothing).

Associated revisions

Revision 73e03bb7 (diff)
Added by Rune Piper about 1 year ago

[BUGFIX] Disable dump autoloading in Composer mode

This patch hides the "Dump autoload" button in the maintenance area when
in Composer mode, because it does nothing.

Resolves: #86565
Releases: master
Change-Id: Ib8f71f5a41189f97f02aed6b4c7cb69feabef724
Reviewed-on: https://review.typo3.org/58578
Tested-by: TYPO3com <>
Reviewed-by: Torben Hansen <>
Reviewed-by: Nikita Hovratov <>
Tested-by: Nikita Hovratov <>
Reviewed-by: Tomas Norre Mikkelsen <>
Reviewed-by: Tobi Kretschmann <>
Tested-by: Tobi Kretschmann <>
Reviewed-by: Frank Naegler <>
Tested-by: Frank Naegler <>

History

#1 Updated by Stephan GroƟberndt about 1 year ago

  • Subject changed from "Dumo autoload" reports green when in composer mode to "Dump autoload" reports green when in composer mode

#2 Updated by Gerrit Code Review about 1 year ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/58578

#3 Updated by Gerrit Code Review about 1 year ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/58578

#4 Updated by Gerrit Code Review about 1 year ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/58578

#5 Updated by Rune Piper about 1 year ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#6 Updated by Benni Mack 7 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF