Bug #86771

Editor without access to default language can not edit translated content element

Added by Jasmina LieƟmann about 1 year ago. Updated 7 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Localization
Target version:
-
Start date:
2018-10-27
Due date:
% Done:

100%

TYPO3 Version:
9
PHP Version:
7.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

If an editor has no access to the default language he cannot edit the translated content elements.

The error message is like:

Call to a member function getLanguageId() on null

This happens in connected mode and free mode in modules "Page" and "List".

Associated revisions

Revision ed0066a3 (diff)
Added by Ursula Klinger about 1 year ago

[BUGFIX] Edit a translated record without def. language access

Editor without access to default language could not edit a translated
content element, because there was an entry in available languages
for index 0 with null

Resolves: #86771
Releases: master
Change-Id: I608791a6df9b26f420fb233d47f38fe7685931c8
Reviewed-on: https://review.typo3.org/58738
Reviewed-by: Felix Althaus <>
Tested-by: Felix Althaus <>
Tested-by: TYPO3com <>
Reviewed-by: Benni Mack <>
Tested-by: Benni Mack <>

History

#1 Updated by Gerrit Code Review about 1 year ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/58738

#2 Updated by Gerrit Code Review about 1 year ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/58738

#3 Updated by Ursula Klinger about 1 year ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#4 Updated by Benni Mack 7 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF