Feature #86908

Poster HTML5 video

Added by ahmad no-lastname-given about 1 year ago. Updated about 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2018-11-11
Due date:
% Done:

0%

PHP Version:
Tags:
Complexity:
Sprint Focus:

Description

Hello,
It seems there is not any option for adding a poster image to HTML5 video tag (typo3/sysext/core/Classes/Resource/Rendering/VideoTagRenderer.php). I've searched in the forge and there is many old closed requests about old video playing JS libraries , but after replacing the current HTML5 video player, Typo3 lacks video poster feature again.

The hard way to achieve this feature is to make automated posters that needs ffmpeg. But at least TYPO3 needs manual posters. There is some suggestions:
1) Use second media element of a content element as a poster. or with a checkbox.
2) The old way is adding a file by similar file-name as a video file-name in the same folder.
3) Adding a specific poster field for video media records and embed it in the code.

Kind Regards


Related issues

Related to TYPO3 Core - Bug #71831: no posterimage for videos New 2015-11-25

History

#1 Updated by Riccardo De Contardi about 1 year ago

  • Related to Bug #71831: no posterimage for videos added

#2 Updated by Riccardo De Contardi about 1 year ago

  • Status changed from New to Closed

I close this issue as a duplicate of #71831 please continue the discussion there. I've added there a reference to this issue to keep track of it.

If you experience the issue again on newer TYPO3 versions, please reopen it or ping me. Thank you.

Also available in: Atom PDF