Bug #87034

Fresh Install Wrong DB Connection Collation

Added by Nils Hodyas 6 months ago. Updated 3 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Install Tool
Target version:
-
Start date:
2018-11-29
Due date:
% Done:

0%

TYPO3 Version:
9
PHP Version:
7.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

I tried to install 9.5.1 with a new, clean DB (on 1&1 IONOS), but the DB connection collation was latin_swedish (the DB itself was utf8). InstallTool refused to proceed. Support said, they would not fix that. End of story.
Related to [[Bug #80733]] and [[Bug #81496]].


Related issues

Related to TYPO3 Core - Bug #80733: Illegal mix of collations (latin1_swedish_ci,IMPLICIT) and (utf8_general_ci,COERCIBLE) Exception while upgrading from 8.6.1 to 8.7.0 Rejected 2017-04-06
Duplicates TYPO3 Core - Bug #81496: Invalid Charset UTF8 at Hoster Strato New 2017-06-07

History

#1 Updated by Susanne Moog 3 months ago

  • Related to Bug #80733: Illegal mix of collations (latin1_swedish_ci,IMPLICIT) and (utf8_general_ci,COERCIBLE) Exception while upgrading from 8.6.1 to 8.7.0 added

#2 Updated by Susanne Moog 3 months ago

  • Duplicates Bug #81496: Invalid Charset UTF8 at Hoster Strato added

#3 Updated by Susanne Moog 3 months ago

  • Tracker changed from Story to Bug
  • Status changed from New to Closed

Thanks for the report, I'm closing it as a duplicate of #81496 talking about the same issue. Please add your points to that issue so that it can be handled "as one". Additionally you might try to run "ALTER DATABASE <databasename> CHARACTER SET utf8 COLLATE utf8_general_ci;" (taken from the link out of the other issue) to try to fix your issue.

Also available in: Atom PDF