Bug #87804

Link/PageViewHelper doesn't force closing tag

Added by Riny van Tiggelen 6 months ago. Updated 3 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2019-02-27
Due date:
% Done:

100%

TYPO3 Version:
9
PHP Version:
Tags:
fluid
Complexity:
Is Regression:
Sprint Focus:

Description

The fluid viewhelper Link/PageViewHelper doesn't force the closing tag, unlike all the other link viewhelpers (who make use of the tagbuilder).

This causes the link to render as <a href="...." /> when there's no content given.

Associated revisions

Revision d9ceaf62 (diff)
Added by Riny van Tiggelen 6 months ago

[BUGFIX] Force closing tag in PageViewHelper

Unlike all the other link viewhelpers (based on tagbuilder),
the PageViewHelper does not force the closing tag which
results in an invalid tag when there is no content available.

Resolves: #87804
Releases: master, 9.5, 8.7
Change-Id: Ia49aaf1f2f80be4fa3febee08f5285bebd2c0189
Reviewed-on: https://review.typo3.org/c/59811
Tested-by: TYPO3com <>
Tested-by: Guido Schmechel <>
Tested-by: Richard Haeser <>
Tested-by: Benni Mack <>
Reviewed-by: Oliver Klee <>
Reviewed-by: Richard Haeser <>
Reviewed-by: André Schließer <>
Reviewed-by: Andreas Fernandez <>
Reviewed-by: Wouter Wolters <>
Reviewed-by: Guido Schmechel <>
Reviewed-by: Benni Mack <>

Revision c5e1d3cb (diff)
Added by Riny van Tiggelen 6 months ago

[BUGFIX] Force closing tag in PageViewHelper

Unlike all the other link viewhelpers (based on tagbuilder),
the PageViewHelper does not force the closing tag which
results in an invalid tag when there is no content available.

Resolves: #87804
Releases: master, 9.5, 8.7
Change-Id: Ia49aaf1f2f80be4fa3febee08f5285bebd2c0189
Reviewed-on: https://review.typo3.org/c/59842
Tested-by: TYPO3com <>
Tested-by: Benni Mack <>
Reviewed-by: Benni Mack <>

Revision f6cc692e (diff)
Added by Riny van Tiggelen 6 months ago

[BUGFIX] Force closing tag in PageViewHelper

Unlike all the other link viewhelpers (based on tagbuilder),
the PageViewHelper does not force the closing tag which
results in an invalid tag when there is no content available.

Resolves: #87804
Releases: master, 9.5, 8.7
Change-Id: Ia49aaf1f2f80be4fa3febee08f5285bebd2c0189
Reviewed-on: https://review.typo3.org/c/59843
Tested-by: TYPO3com <>
Tested-by: Benni Mack <>
Reviewed-by: Oliver Klee <>
Reviewed-by: Benni Mack <>

History

#1 Updated by Gerrit Code Review 6 months ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/59811

#2 Updated by Gerrit Code Review 6 months ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/59811

#3 Updated by Gerrit Code Review 6 months ago

Patch set 1 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/59842

#4 Updated by Riny van Tiggelen 6 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#5 Updated by Gerrit Code Review 6 months ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/59843

#6 Updated by Riny van Tiggelen 6 months ago

  • Status changed from Under Review to Resolved

#7 Updated by Benni Mack 3 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF