Bug #87913

Remove playlist parameter from YouTube URL if it should play in loop

Added by Sascha Egerer 4 months ago. Updated 4 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
Start date:
Due date:
% Done:

0%

TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
no-brainer
Is Regression:
Sprint Focus:

Description

In #78053 a change was introduced in the YouTubeRenderer to always add a playlist if the "loop" option is set.
The reason was, that the playlist parameter was required by YouTube but this is not true actually. It was only required for the deprecated AS3 Flash player.

See https://developers.google.com/youtube/player_parameters#loop

Note: This parameter has limited support in the AS3 player and in IFrame embeds, which could load either the AS3 or HTML5 player. Currently, the loop parameter only works in the AS3 player when used in conjunction with the playlist parameter. To loop a single video, set the loop parameter value to 1 and set the playlist parameter value to the same video ID already specified in the Player API URL:

The playlist param must not be set automatically as it does add a playlist to the video which contains the same video 2 times and does not really look good.

With playlist

without playlist

withPlaylist.png View (279 KB) Sascha Egerer, 2019-03-14 17:05

withoutPlaylist.png View (160 KB) Sascha Egerer, 2019-03-14 17:05

playlist.png View (112 KB) Sascha Egerer, 2019-03-14 17:05


Related issues

Follows TYPO3 Core - Bug #78053: "loop" parameter require "playlist" parameter for embedded Youtube videos & Allow configuration for "autohide" and "controls" Closed 2016-09-23

History

#1 Updated by Sascha Egerer 4 months ago

  • Due date set to 2016-09-26
  • Start date changed from 2019-03-14 to 2016-09-26
  • Follows Bug #78053: "loop" parameter require "playlist" parameter for embedded Youtube videos & Allow configuration for "autohide" and "controls" added

#2 Updated by Sascha Egerer 4 months ago

  • Due date deleted (2016-09-26)
  • Start date deleted (2016-09-26)

#3 Updated by Gerrit Code Review 4 months ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/60247

#4 Updated by Sascha Egerer 4 months ago

  • Status changed from Under Review to Closed

Ok lets keep it as it is. YouTube is really not doing what the API says.
The loop does not work if you do only define a video with the loop parameter. You can define no video in the url and the video as playlist but in this case the autoplay does not work. So looks like the current state of youtube is that we have to live with the playlist overlay in the video that contains the same video 2 times

Also available in: Atom PDF