Bug #78053

"loop" parameter require "playlist" parameter for embedded Youtube videos & Allow configuration for "autohide" and "controls"

Added by Cyril Janody almost 3 years ago. Updated 11 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2016-09-23
Due date:
% Done:

100%

Estimated time:
0.50 h
TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
no-brainer
Is Regression:
No
Sprint Focus:
On Location Sprint

Description

The YouTubeRenderer currently does not force the "playlist" url parameter when setting looping but it should be.

http://www.youtube.com/v/VIDEO_ID?version=3&loop=1&playlist=VIDEO_ID

https://developers.google.com/youtube/player_parameters#loop

YoutubeRenderer.patch View (1.69 KB) Cyril Janody, 2016-09-23 18:54


Related issues

Precedes TYPO3 Core - Bug #87913: Remove playlist parameter from YouTube URL if it should play in loop Closed

Associated revisions

Revision 26541d91 (diff)
Added by Wouter Wolters almost 3 years ago

[BUGFIX] Fix requiring playlist argument when "loop" is set

The YouTubeRenderer does not force the playlist argument yet
when the loop argument is set to 1. According to the documentation
this is required for a single video player. See
https://developers.google.com/youtube/player_parameters#loop

Resolves: #78053
Releases: master,7.6
Change-Id: Ife89cce318347aa6fa1694b90c71d9931538aa4e
Reviewed-on: https://review.typo3.org/50076
Reviewed-by: Joerg Boesche <>
Reviewed-by: Jan Helke <>
Tested-by: Jan Helke <>
Tested-by: TYPO3com <>
Reviewed-by: Stefan Neufeind <>
Tested-by: Stefan Neufeind <>

Revision f3317ce7 (diff)
Added by Wouter Wolters almost 3 years ago

[BUGFIX] Fix requiring playlist argument when "loop" is set

The YouTubeRenderer does not force the playlist argument yet
when the loop argument is set to 1. According to the documentation
this is required for a single video player. See
https://developers.google.com/youtube/player_parameters#loop

Resolves: #78053
Releases: master,7.6
Change-Id: Ife89cce318347aa6fa1694b90c71d9931538aa4e
Reviewed-on: https://review.typo3.org/50093
Reviewed-by: Stefan Neufeind <>
Tested-by: TYPO3com <>
Reviewed-by: Benni Mack <>
Tested-by: Benni Mack <>

History

#1 Updated by Cyril Janody almost 3 years ago

  • Subject changed from "loop" parameter require "playlist" parameter for embedded Youtube videos & Allowing configuration for "autohide" and "controls" to "loop" parameter require "playlist" parameter for embedded Youtube videos & Allow configuration for "autohide" and "controls"

#2 Updated by Gerrit Code Review almost 3 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50076

#3 Updated by Gerrit Code Review almost 3 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50076

#4 Updated by Jan Helke almost 3 years ago

  • Sprint Focus set to On Location Sprint

#5 Updated by Gerrit Code Review almost 3 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50076

#6 Updated by Gerrit Code Review almost 3 years ago

Patch set 1 for branch TYPO3_7-6 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50093

#7 Updated by Wouter Wolters almost 3 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#8 Updated by Benni Mack 11 months ago

  • Status changed from Resolved to Closed

#9 Updated by Sascha Egerer 5 months ago

  • Precedes Bug #87913: Remove playlist parameter from YouTube URL if it should play in loop added

Also available in: Atom PDF