Bug #88278

felogin redirect not working if Hide At Login is set

Added by Kuba Wolski over 3 years ago. Updated over 3 years ago.

Status:
Rejected
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2019-05-06
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

I use single page to serve as login page and content after login.
I set redirect after successful login to follow PRG pattern (https://en.wikipedia.org/wiki/Post/Redirect/Get)
I also want to hide login form or any other felogin component from view, so I set Hide At Login in Access tab of felogin plugin edit form in Typo3 BE.
After successful login redirect does not happen, as plugin is hidden and cannot proceed any redirects.

I think, after successful login, felogin should allow plugin to follow any redirect rules.

#1

Updated by Kuba Wolski over 3 years ago

Typo3 v9.5.5
felogin v9.5.5

#2

Updated by Georg Ringer over 3 years ago

  • Status changed from New to Rejected

Thanks for creating the issue. I am rejecting this issue because it is simply not possible. If you don't let TYPO3 render the plugin, it can't to the redirect!

I propose to not set the "hide after login" and use an empty template and everything should be fine.

Also available in: Atom PDF