Bug #88329

backend layout restrictions won't work after update to 9.5.6

Added by Florian Schuhmann 4 months ago. Updated 4 months ago.

Status:
Rejected
Priority:
Must have
Assignee:
-
Category:
Backend User Interface
Target version:
-
Start date:
2019-05-10
Due date:
% Done:

0%

TYPO3 Version:
9
PHP Version:
7.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

After the update from 9.5.5 to 9.5.6 backend layout restrictions for content elements won't work.

1 {
    columns {
        1 {
            name = HERO
            colPos = 1
            allowed {
                CType = hero
            }
        }
    }
}

So with TYPO3 v9.5.6 all Content Elements are shown and not only the allowed one

History

#1 Updated by Jan Delius 4 months ago

Since the kernel does not have this limitation at all, this is not an error of the basic system.

If you're using gridelements, this issue is already reported at https://gitlab.com/coderscare/gridelements/issues/34

#2 Updated by Florian Schuhmann 4 months ago

Ok thanks for reply, than this is a bug within gridelements.
I thought the limitation is also included in the core.

#3 Updated by Andreas Fernandez 4 months ago

  • Status changed from New to Rejected

Closed as this is not a core issue for now.

Also available in: Atom PDF