Bug #88342

Typo3 8.7 Backend: Close content element is not working in Google Chrome

Added by Patrick Gaiser 7 months ago. Updated 7 months ago.

Status:
Rejected
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2019-05-13
Due date:
% Done:

0%

TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

1. Scenario:
After editing a content element in Typo3 Backend you can close the element without saving it.
Problem:
When you click the "x" button nothing happens.

2. Scenario:
After editing a content element in Typo3 Backend you can push the "Save and close" button.
Problem:
The element will not be closed.
The item shows only the load symbol (see picture typo3_chrome_save_and_close_2.jpg).
Refreshing the page manually shows that changes in the content element were saved.

Typo3 CMS 8.7.25
Google Chrome Version 74.0.3729.131 (64-Bit)
PHP Version 7.1.29
MySQL 5.7.26

typo3_chrome_save_and_close_1.jpg View (14.7 KB) Patrick Gaiser, 2019-05-13 14:46

typo3_chrome_save_and_close_2.jpg View (2.69 KB) Patrick Gaiser, 2019-05-13 14:46

History

#1 Updated by Josef Glatz 7 months ago

  • Status changed from New to Needs Feedback

Can't reproduce both scenarios with same Chrome version with latest 8-master branch.

Patrick, can you please check what errors you get in you DevTools Console and/or in the network tab or from any PHP error log or webserver log?
Do you use any other extension within the backend like gridelements or some other enhancement extension?

#2 Updated by Patrick Gaumond 7 months ago

We tested here under Chrome Mac and Windows and can't reproduce.

We use Grid Elements and have a patched version with fix for https://forge.typo3.org/issues/87971 (https://review.typo3.org/c/Packages/TYPO3.CMS/+/60721).

#3 Updated by Patrick Gaiser 7 months ago

It seems to be an internal problem with mixed content. We have to review our code.
Following error occurs when closing or "Save and close" the content element.

Mixed Content: The page at 'https://www.domain.com/typo3/index.php?route=%2Fmain&token=82816321642eea24198efae28457d6a65ccefc7c' was loaded over HTTPS, but requested an insecure form action 'http://www.domain.com/typo3/index.php?M=web_layout&moduleToken=ad3b1c2bd00e5e06acaf0b7da9e62ffc29618b50&id=960#element-tt_content-55834'. This request has been blocked; the content must be served over HTTPS.

Thank you for your support!

#4 Updated by Josef Glatz 7 months ago

  • Status changed from Needs Feedback to Rejected

#5 Updated by Josef Glatz 7 months ago

Patrick Gaiser wrote:

It seems to be an internal problem with mixed content. We have to review our code.
Following error occurs when closing or "Save and close" the content element.

Mixed Content: The page at 'https://www.domain.com/typo3/index.php?route=%2Fmain&token=82816321642eea24198efae28457d6a65ccefc7c' was loaded over HTTPS, but requested an insecure form action 'http://www.domain.com/typo3/index.php?M=web_layout&moduleToken=ad3b1c2bd00e5e06acaf0b7da9e62ffc29618b50&id=960#element-tt_content-55834'. This request has been blocked; the content must be served over HTTPS.

Thank you for your support!

Thank you for the quick feedback :-)

Also available in: Atom PDF