Bug #88626

Context API is not used in TemplateService->versionOL

Added by Benni Mack 5 months ago. Updated 4 months ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
TypoScript
Start date:
2019-06-25
Due date:
% Done:

100%

TYPO3 Version:
10
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Associated revisions

Revision 54ddc9bb (diff)
Added by Benni Mack 5 months ago

[BUGFIX] Use Context API for TemplateService->versionOL

The Context API can be used now within
TemplateService to fetch a version overlay, which now
only relies on the PageRepository (which also uses Context API),
to avoid certain magic detection of Frontend/Backend mode.

TemplateService is only used to fetch sys_template
records in this use-case.

Resolves: #88626
Releases: master
Change-Id: I5f6526868af090915748031d50eeaf245049e655
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/61126
Tested-by: TYPO3com <>
Tested-by: Daniel Gorges <>
Tested-by: Daniel Goerz <>
Reviewed-by: Daniel Gorges <>
Reviewed-by: Daniel Goerz <>

History

#1 Updated by Gerrit Code Review 5 months ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61126

#2 Updated by Benni Mack 5 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#3 Updated by Benni Mack 4 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF