Bug #88781

UI improvements for page clearing action

Added by Nicole Cordes 5 months ago. Updated 4 months ago.

Status:
Resolved
Priority:
Should have
Assignee:
Category:
-
Target version:
-
Start date:
2019-07-16
Due date:
% Done:

100%

TYPO3 Version:
10
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Due to the changes done in https://forge.typo3.org/issues/88718 the user experience should be improved.

before:
- the user saw an action happening after he/she pressed the button
- he/she knew about reloading and waiting time
after:
- no visual action seen anymore; the button can be pressed multiple times
=> maybe the button should turn into a spinner and be disabled after the first usage as long as the request takes
- if the user changes the view (e.g. views another page, edit the page or a content element) the browser (at least chrome) stops the asynchrone request immediately; no further notification for the user will be shown
=> the user should be informed that the "clearing request" is still in progress and gets aborted if the view is changed

Furthermore I think there should be some conceptional work on how to deal with the actions in context menu. Currently there is no visible processing (at least for cache clearing) either. Some wild proposals from my side: a spinning icon in the page tree if any action was chosen or an overall ajax processing queue that is visible e.g. within the top bar.

Associated revisions

Revision 81844b40 (diff)
Added by Daniel Windloff 4 months ago

[BUGFIX] Clear page cache: show status, prevent multiple clicks

Replace the clear cache button with a spinner during the AJAX request.
While the request is executed, the button is no clickable due to
addiional properties and classes being set.

Resolves: #88781
Releases: master
Change-Id: I06d53010d8bd5435ac6fc91ea17ecc6378043f14
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/61307
Tested-by: Andreas Fernandez <>
Tested-by: TYPO3com <>
Tested-by: Frank Naegler <>
Reviewed-by: Andreas Fernandez <>
Reviewed-by: Frank Naegler <>

History

#1 Updated by Daniel Windloff 5 months ago

Hi Nicole,

the issue, I had in the past, was that there was no notification after successful "cache clearing".

Regarding your issues:
- no visual action seen anymore; the button can be pressed multiple times
=> maybe the button should turn into a spinner and be disabled after the first usage as long as the request takes

Ok. Disable the button and change to a spinner is good. I did not run into the issue, as the clear page cache action on my test system is too fast.

- if the user changes the view (e.g. views another page, edit the page or a content element) the browser (at least chrome) stops the asynchrone request immediately; no further notification for the user will be shown
=> the user should be informed that the "clearing request" is still in progress and gets aborted if the view is changed

The icon change would be already a status information. It could not be enough, but on fast systems it could be not a good idea to change information too fast.

Furthermore I think there should be some conceptional work on how to deal with the actions in context menu. Currently there is no visible processing (at least for cache clearing) either. Some wild proposals from my side: a spinning icon in the page tree if any action was chosen or an overall ajax processing queue that is visible e.g. within the top bar.

Atm I have no real solution for this issue.
(The context menu could be reached from other places (list module, page module, backend user module, ...). So even the page tree is not always available.)

#2 Updated by Gerrit Code Review 5 months ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61307

#3 Updated by Gerrit Code Review 4 months ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61307

#4 Updated by Gerrit Code Review 4 months ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61307

#5 Updated by Gerrit Code Review 4 months ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61307

#6 Updated by Daniel Windloff 4 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF