Bug #89035

URLs with invalid language path segment are redirected to default language

Added by Helmut Hummel over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2019-08-28
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Given a site configuration with two languages and their base paths '/dk/' and '/en/' exist.
Given '/dk/' is the path for the default language

When a URL without path is requested ('/')
I would expect to see a 307 redirect to '/dk/', which is what also actually happens.

But:

When a URL is requested that has no matching language segment (e.g. '/foo/')
I would expect to see a 404 response.

What actually happens is a 307 redirect response to '/dk/'.


Related issues

Is duplicate of TYPO3 Core - Bug #88838: Improved 404 handling for multi-lingual websitesClosed2019-07-24

Actions
#1

Updated by Helmut Hummel over 1 year ago

  • Is duplicate of Bug #88838: Improved 404 handling for multi-lingual websites added
#2

Updated by Helmut Hummel over 1 year ago

  • Status changed from New to Closed

duplicate

Also available in: Atom PDF