Bug #89484

Use SiteLanguage hreflang for html-tag lang-attribute

Added by David Gurk almost 2 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
Frontend
Target version:
-
Start date:
2019-10-23
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
easy
Is Regression:
Sprint Focus:

Description

Currently TYPO3 uses the iso-639-1 code for the html-tag lang-attribute like: <html lang="[iso-639-1]">

See:
https://github.com/TYPO3/TYPO3.CMS/blob/9.5/typo3/sysext/frontend/Classes/Http/RequestHandler.php#L294

While Google ignores this attribute, the lang-attribute could and should use the hreflang of the SiteLanguage configuration.


Related issues

Related to TYPO3 Core - Bug #90641: Setting hreflang to "x-default" break html-lang attributeClosedSimon Gilli2020-03-04

Actions
#1

Updated by Gerrit Code Review almost 2 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/62081

#2

Updated by Simon Gilli almost 2 years ago

  • Category set to Frontend
  • Assignee set to Simon Gilli
  • % Done changed from 0 to 100
  • Complexity set to easy
#3

Updated by Gerrit Code Review almost 2 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/62081

#4

Updated by Gerrit Code Review almost 2 years ago

Patch set 1 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/62062

#5

Updated by Gerrit Code Review almost 2 years ago

Patch set 2 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/62062

#6

Updated by Simon Gilli almost 2 years ago

  • Status changed from Under Review to Resolved
#7

Updated by Benni Mack almost 2 years ago

  • Status changed from Resolved to Closed
#8

Updated by Simon Gilli over 1 year ago

  • Related to Bug #90641: Setting hreflang to "x-default" break html-lang attribute added

Also available in: Atom PDF