Project

General

Profile

Actions

Bug #89851

closed

Fluid Styled Content Layout ignores sectionIndex setting

Added by Jo Hasenau about 4 years ago. Updated about 4 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
Fluid Styled Content
Target version:
Start date:
2019-12-04
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
easy
Is Regression:
Sprint Focus:

Description

Depending on the setting of the frame_class field, Fluid Styled Content renders two different variants of ids/anchors.

With a frame it will be

<div id="c{data.uid}" class="frame frame-{data.frame_class} frame-type-{data.CType} frame-layout-{data.layout}{f:if(condition: data.space_before_class, then: ' frame-space-before-{data.space_before_class}')}{f:if(condition: data.space_after_class, then: ' frame-space-after-{data.space_after_class}')}">
    <f:if condition="{data._LOCALIZED_UID}">
        <a id="c{data._LOCALIZED_UID}"></a>
    </f:if>
    ....
</div>

without a frame it will be

<a id="c{data.uid}"></a>
<f:if condition="{data._LOCALIZED_UID}">
    <a id="c{data._LOCALIZED_UID}"></a>
</f:if>

In the first case there will be just one additional <a> Tag, in the second there will be two.
Both of them should be removed as soon as the field sectionIndex ("Show in section menus") is disabled, since otherwise those anchors will break the HTML code by adding unwanted tags.
Currently the switch has no impact and the tags will always there in CMS 8, 9 and 10.

Actions #1

Updated by Jo Hasenau about 4 years ago

  • Status changed from New to Closed
Actions

Also available in: Atom PDF