Bug #89977

Exception in BE after Update to 9.5.12: missing function contentIsNotLockedForEditors?

Added by Sybille Peters 11 months ago. Updated 11 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend API
Target version:
-
Start date:
2019-12-17
Due date:
% Done:

0%

TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

This leads to a problem with gridelements.

Editors (non admins) will get an Exception in BE (in page module), if a page is selected.


see: typo3/sysext/backend/Classes/


typo3/sysext/backend/Classes/Controller/PageLayoutController.php:        'contentIsNotLockedForEditors' => 'Using PageLayoutController::contentIsNotLockedForEditors() is deprecated and will not be possible anymore in TYPO3 v10.0.',


It appears that it was intended to deprecate this function but it seems to have disappeared?


There is currently no update for gridelements. I am using 9.3.0


Related issues

Related to TYPO3 Core - Bug #89975: Removed method in PageLayoutController breaks gridelements Closed 2019-12-17

History

#1 Updated by Sybille Peters 11 months ago

  • Description updated (diff)

#2 Updated by Sybille Peters 11 months ago

  • Status changed from New to Closed

This has already been taken care of: https://review.typo3.org/c/Packages/TYPO3.CMS/+/62731

#89975

Closing.

#3 Updated by Sybille Peters 11 months ago

  • Related to Bug #89975: Removed method in PageLayoutController breaks gridelements added

Also available in: Atom PDF