Bug #90005

Get Parameter "id" leads to 404

Added by Martin Weymayer 2 months ago. Updated 2 months ago.

Status:
Rejected
Priority:
Should have
Assignee:
-
Category:
Frontend
Target version:
-
Start date:
2019-12-22
Due date:
% Done:

0%

TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

I have extension with payment provider service. On success page payment provider is adding automatically some get paramters to identify payment. Also "id" is a get paramter. Successpage Payment provider is redirecting to is like:
www.domain.at/success?id=E132asfasd321as0973CCFC80AD.prasdf01-vm-tasdsdfasdfasdfrcePath=/v1/checkouts/8121212aa21as21323,21afasdf0AD.pasfsd-asdfasd01/asdfasdt

Since last update 9.5.13 success page is not working any more becace TYPO3 is checking "id" with pages-id. So id E132asfasd321as0973CCFC80AD.prasdf01-vm-tasdsdfasdfasdfr... of course does not exist and so 404 page is shown. There must be some settings to (certain pages?) exclude the get parameter from 404 handling.

Martin

History

#1 Updated by Georg Ringer 2 months ago

  • Status changed from New to Rejected

Thanks for creating the issue. However I will still reject that issue as the ID parameter is a global one and still a fallback in typo3 for page ids.

Please use a custom Middleware to unset the parameter yourself.

Also available in: Atom PDF