Bug #90219

"Database name not valid" with sqlite and long path name

Added by Daniel Siepmann 28 days ago. Updated 5 days ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Database API (Doctrine DBAL)
Target version:
-
Start date:
2020-01-27
Due date:
% Done:

0%

TYPO3 Version:
10
PHP Version:
7.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

I receive the following issue with my current local Setup:

Database name not valid
Given database name must be shorter than fifty characters and consist solely of basic latin letters (a-z), digits (0-9), dollar signs ($) and underscores (_).

The setup uses current TYPO3 Master (as of writing), via composer using sqlite as configured database.
The error is shown in "Environment Status".

I would guess the issue is set in typo3/sysext/install/Classes/SystemEnvironment/DatabaseCheck/Platform/AbstractPlatform.php and there should be a special handling for sqlite which doesn't limit to 50 characters for the sqlite file path?

With this bug in place, it's very hard to get a clean system report (which also executes the environment check).
Leading to spam like this:

Issues:
[ERR] System environment check - 1 Test(s)
  1. Database name not valid: 2

Related issues

Duplicates TYPO3 Core - Feature #85739: Reduce restrictions on database names introduced for DBAL Under Review 2018-08-02

History

#1 Updated by Daniel Siepmann 28 days ago

  • Description updated (diff)

#2 Updated by Daniel Siepmann 5 days ago

  • Duplicates Feature #85739: Reduce restrictions on database names introduced for DBAL added

#3 Updated by Daniel Siepmann 5 days ago

  • Status changed from New to Closed

Also available in: Atom PDF