Bug #90287

SendMailCommand not usable inside scheduler, because of missing possibility to configure

Added by Alexander Grein 24 days ago. Updated 4 days ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
CLI
Start date:
2020-01-31
Due date:
% Done:

0%

TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

If you try to use the new swiftmailer spool feature by e.g.

MAIL => ['transport_spool_type' => 'file']

it's currently not possible to trigger the sending by adding a task to the TYPO3 scheduler, because of SendMailCommand uses options instead of attributes for configuration.
Because of this, no configuration is possible there.

The only way to adjust the maximum number of messages to send (message-limit), the time limit for sending messages in seconds (time-limit) and the timeout for recovering messages that have taken too long to send in seconds (recover-timeout) for one call is currently to add an extra cron job.

History

#1 Updated by Alexander Grein 6 days ago

Could be marked as solved, because of

2020-01-16 9dc20efbd6 [BUGFIX] Add support for options in "Execute console commands" (thanks to Sebastian Mazza)

in Version 9.5.14

#2 Updated by Susanne Moog 4 days ago

  • Status changed from New to Closed

See previous comment.

Also available in: Atom PDF