Bug #90349

conflicting permissions when UID in pages_language_overlay and PID in pages coincide

Added by Barbara Reiter 15 days ago. Updated 10 days ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2020-02-10
Due date:
% Done:

0%

TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

In a multidomain setup with different permission groups and backend users, an alternative page language record has the same UID as the PID of another page.
The relevant pages are part of different permission groups.

The user has permission to edit page A and should therefore be able to edit it's translation, but he has no permission for page B.

The user tries to edit the alternative page language of page A, which he has permission for but gets an error that he has no permission to do so, with the UID of the translation(page A)/the PID of the coinciding page (page B) being quoted in the error.

It seems as if Typo3 interprets the action as the user trying to access the page with the PID they have no permission for (page B), when they are only trying to access the translation of a page they do have permission for (page A).

Steps to reproduce:
  • Create a page (assuming PID 1)
  • Create second page (assuming PID 2)
  • localize second page into other language
  • check if UID of translation is the same as PID of first page (PID 1)
  • create a backend user with the permission for translations and second page, but not first page
  • try to edit the translation
  • User should get an error similar to attached screenshot

permission_error.PNG View (4.24 KB) Barbara Reiter, 2020-02-10 11:15

History

#1 Updated by Barbara Reiter 15 days ago

Realized after posting, that issue occurs when the page where the PID (page B) coincides with the UID of the translation (page A) is a page root.

#2 Updated by Georg Ringer 10 days ago

  • Status changed from New to Needs Feedback

Hi,

thanks for creating this issue! Even though this is valid this won't be changed anymore as TYPO3 8 is end of live very soon and it has been solved in 9 because pages_language_overlay is gone there.

#3 Updated by Georg Ringer 10 days ago

  • Status changed from Needs Feedback to Closed

Also available in: Atom PDF