Task #90365

Use Symfony 4 LTS versions in TYPO3 v9

Added by Benni Mack 12 days ago. Updated 12 days ago.

Status:
Resolved
Priority:
Should have
Assignee:
Category:
composer
Start date:
2020-02-12
Due date:
% Done:

100%

TYPO3 Version:
10
PHP Version:
Tags:
Complexity:
Sprint Focus:

Associated revisions

Revision 61b25428 (diff)
Added by Benni Mack 12 days ago

[TASK] Raise symfony dependencies to their LTS versions

TYPO3 uses several symfony components. The latest
releases of Symfony (4.4) are LTS versions, which
should be shipped with TYPO3 Core by default when
downloading TYPO3 as tarball artefacts.

Only TYPO3 v9 is affected, since TYPO3 v10 already
incorporates Symfony 4.4 / Symfony 5.0.

Resolves: #90365
Releases: 9.5
Change-Id: I0d1209a9e08f8df3aeb50a3e4dc3d5f9dad6252d
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/63210
Tested-by: TYPO3com <>
Tested-by: Georg Ringer <>
Tested-by: Benni Mack <>
Reviewed-by: Georg Ringer <>
Reviewed-by: Benni Mack <>

History

#1 Updated by Gerrit Code Review 12 days ago

  • Status changed from New to Under Review

Patch set 1 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/63210

#2 Updated by Benni Mack 12 days ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF