Bug #90515

New fluid based PageLayoutView does not work with sqlite3

Added by Daniel Siepmann 3 months ago. Updated 3 months ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
-
Start date:
2020-02-24
Due date:
% Done:

100%

TYPO3 Version:
10
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Right now sqlite3 returns non casted values, all values are strings.
The code expects int types but doesn't cast them, leading to the following issues in some places:

 (1/1) TypeError

Argument 1 passed to TYPO3\CMS\Backend\View\BackendLayout\RecordRememberer::isRemembered() must be of the type int, string given,

Associated revisions

Revision 2618039a (diff)
Added by Daniel Siepmann 3 months ago

[BUGFIX] Cast to prevent PHP TypeError when using sqlite

sqlite3 doesn't return casted values right now, everything is a string.
Some methods require integers, e.g. uid of a record. In order to prevent
TypeError due to mismatch, values are casted to integer.

Resolves: #90515
Releases: master
Change-Id: Ibb1654a412f94b5bd511dac5bed75a1af0683fe9
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/63399
Reviewed-by: Björn Jacob <>
Reviewed-by: Markus Klein <>
Reviewed-by: Christian Eßl <>
Reviewed-by: Claus Due <>
Reviewed-by: Georg Ringer <>
Tested-by: Markus Klein <>
Tested-by: Christian Eßl <>
Tested-by: TYPO3com <>
Tested-by: Claus Due <>
Tested-by: Georg Ringer <>

History

#1 Updated by Gerrit Code Review 3 months ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/63399

#2 Updated by Gerrit Code Review 3 months ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/63399

#3 Updated by Daniel Siepmann 3 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#4 Updated by Benni Mack 3 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF