Bug #91950

Reverting redirect via ajax fails when using sqlite

Added by Daniel Siepmann 4 months ago. Updated 3 months ago.

Status:
Closed
Priority:
Should have
Category:
-
Start date:
2020-08-07
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
10
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

When using sqlite, data fetched from DB is not casted. Therefore the record uid is an string instead of integer.
This conflicts with strict type annotation.

Steps to reproduce:
Open a page record, change slug and save.
TYPO3 should now show an notification with two actions.
Select "Revert redirects only".
This should result in an 500 due to the mentioned issue.

#1

Updated by Gerrit Code Review 4 months ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/65222

#2

Updated by Gerrit Code Review 4 months ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/65222

#3

Updated by Gerrit Code Review 4 months ago

Patch set 1 for branch 10.4 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/65210

#4

Updated by Daniel Siepmann 4 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#5

Updated by Benni Mack 3 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF