Bug #92314

FixVersioningPid does unnecessary DB calls

Added by Benni Mack 10 days ago. Updated 8 days ago.

Status:
Resolved
Priority:
Should have
Assignee:
Category:
Workspaces
Start date:
2020-09-16
Due date:
% Done:

100%

TYPO3 Version:
11
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Associated revisions

Revision ad2900c8 (diff)
Added by Benni Mack 8 days ago

[BUGFIX] Only fix versioning PID for moved records

Since the removal of "pid=-1" in TYPO3 v10, it is not necessary
to fix the versioning PID for all versioned records anymore.

The checks in BackendUtility::fixVersioningPid() and
PageRepository->fixVersioningPid() are cleaned up, because:

  • The only version type that has a DIFFERENT page ID than
    its online pendant is the MOVE_POINTER (t3ver_state=4)
  • The MOVE_PLACEHOLDER does not contain a t3ver_oid
    and is not evaluated ever in these methods
  • All other t3ver_state items have the same PID as the live
    version, and should not be evaluated.

Resolves: #92314
Releases: master, 10.4
Change-Id: I0551547bd2bb9f469ed3a68396b74c0d4de1a18d
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/65705
Tested-by: TYPO3com <>
Tested-by: Oliver Bartsch <>
Tested-by: Christian Kuhn <>
Tested-by: Benni Mack <>
Reviewed-by: Oliver Bartsch <>
Reviewed-by: Christian Kuhn <>
Reviewed-by: Benni Mack <>

Revision 8b5bbd05 (diff)
Added by Benni Mack 8 days ago

[BUGFIX] Only fix versioning PID for moved records

Since the removal of "pid=-1" in TYPO3 v10, it is not necessary
to fix the versioning PID for all versioned records anymore.

The checks in BackendUtility::fixVersioningPid() and
PageRepository->fixVersioningPid() are cleaned up, because:

  • The only version type that has a DIFFERENT page ID than
    its online pendant is the MOVE_POINTER (t3ver_state=4)
  • The MOVE_PLACEHOLDER does not contain a t3ver_oid
    and is not evaluated ever in these methods
  • All other t3ver_state items have the same PID as the live
    version, and should not be evaluated.

Resolves: #92314
Releases: master, 10.4
Change-Id: I0551547bd2bb9f469ed3a68396b74c0d4de1a18d
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/65772
Tested-by: TYPO3com <>
Tested-by: Benni Mack <>
Reviewed-by: Benni Mack <>

History

#1 Updated by Gerrit Code Review 10 days ago

  • Status changed from New to Under Review

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/65705

#2 Updated by Gerrit Code Review 8 days ago

Patch set 1 for branch 10.4 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/65772

#3 Updated by Benni Mack 8 days ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF