Bug #92549

Config of extbase database Mapping sometimes is not effective

Added by Timo Poppinga 11 days ago. Updated 7 days ago.

Status:
Rejected
Priority:
Should have
Assignee:
-
Category:
Extbase
Target version:
-
Start date:
2020-10-12
Due date:
% Done:

0%

TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Uncaught TYPO3 Exception: #1472074485: Table 'xxx.tx_xxx_domain_model_page' doesn't exist | TYPO3\CMS\Extbase\Persistence\Generic\Storage\Exception\SqlErrorException thrown in file typo3/sysext/extbase/Classes/Persistence/Generic/Storage/Typo3DbBackend.php in line 375

Sometimes i do have this error logged. In this case TYPO3 cannot render the page.
It's hard to reproduce because it occur suddenly and not planebal.

I found out:

1. Clearing the cache helps so i think TYPO3 somehow caches an wrong ts setup
2. If this Error accour the TypoScript mapping config dose not exist
3. It start to accour later than v9.5.19

History

#1 Updated by Timo Poppinga 10 days ago

  • Subject changed from Config aof extbase database Mapping sometimes is not effective to Config of extbase database Mapping sometimes is not effective

#2 Updated by Timo Poppinga 10 days ago

followup: In projects where this issue occurs are we using PSR middleware to provide an API. May its connected to this - could be that in this process an wrong typoscript is build.

#3 Updated by Georg Ringer 10 days ago

  • Status changed from New to Rejected

thanks for creating the issue. TBH I would try to update to 10 LTS as this has been removed from TS into a dedicated registry, see https://docs.typo3.org/c/typo3/cms-core/master/en-us/Changelog/10.0/Breaking-87623-ReplaceConfigpersistenceclassesTyposcriptConfiguration.html.

even though the issue is valid, we won't change anything for version 9 anymore in that regard.

#4 Updated by Timo Poppinga 7 days ago

Hi Georg, thanks for the answer. The upgrade to Version 10 is already in the pipeline. Most likely it will will be fixed in version 10. We make the experience In other Projects running on 10 the mapping works totally fine. I will come back to tell you the result after upgrding the project to 10

Also available in: Atom PDF