Project

General

Profile

Actions

Bug #92986

closed

RedirectFinisher broken with integer pageUid

Added by Andreas Kienast about 3 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Must have
Category:
Form Framework
Target version:
Start date:
2020-12-04
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
10
PHP Version:
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

If the RedirectFinisher is used with a pageUid of type integer (as documented), the redirect goes to pageUid 0, as with #92112 the value must be of type string.


Related issues 2 (0 open2 closed)

Related to TYPO3 Core - Task #92112: Fix phpstan checkFunctionArgumentTypes errors in ext:formClosed2020-08-26

Actions
Is duplicate of TYPO3 Core - Bug #92800: Redirects not working correctly in redirectfinisher of EXT:formClosed2020-11-08

Actions
Actions #1

Updated by Andreas Kienast about 3 years ago

  • Related to Task #92112: Fix phpstan checkFunctionArgumentTypes errors in ext:form added
Actions #2

Updated by Gerrit Code Review about 3 years ago

  • Status changed from In Progress to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/66993

Actions #3

Updated by Andreas Kienast about 3 years ago

  • Status changed from Under Review to Closed

Dupe of #92800

Actions #4

Updated by Andreas Kienast about 3 years ago

  • Is duplicate of Bug #92800: Redirects not working correctly in redirectfinisher of EXT:form added
Actions

Also available in: Atom PDF