Project

General

Profile

Actions

Bug #93167

closed

InlineControlContainer.js Error in >v10.4.11 for type = ‘inline’:tt_content

Added by Oleg Karun about 3 years ago. Updated about 3 years ago.

Status:
Rejected
Priority:
Should have
Assignee:
-
Category:
AdminPanel
Target version:
Start date:
2020-12-24
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
10
PHP Version:
7.4
Tags:
Complexity:
medium
Is Regression:
Sprint Focus:

Description

When I try to add a new element


All fields empty and just RTE show added text

Have this error

Same problem with regular/core Fluid Elements

Tested with news:8.5.0. extension but also repeated with black TCA


'content_elements' => [
'exclude' => true,
'label' => $ll . 'tx_news_domain_model_news.content_elements',
'config' => [
'type' => 'inline',
'allowed' => 'tt_content',
'foreign_table' => 'tt_content',
'foreign_sortby' => 'sorting',
'foreign_field' => 'tx_news_related_news',
'minitems' => 0,
'maxitems' => 99,
'appearance' => [
'useXclassedVersion' => $configuration->getContentElementPreview(),
'collapseAll' => true,
'expandSingle' => true,
'levelLinksPosition' => 'bottom',
'useSortable' => true,
'showPossibleLocalizationRecords' => true,
'showRemovedLocalizationRecords' => true,
'showAllLocalizationLink' => true,
'showSynchronizationLink' => true,
'enabledControls' => [
'info' => false,
]
],
'behaviour' => [
'allowLanguageSynchronization' => true,
],
]
],

It seems the problem is a change in the file from TYPO3v 10.4.10 to v 10.4.11: typo3_src\typo3\sysext\backend\Resources\Public\JavaScript\FormEngine\Container\InlineControlContainer.js
When using the same file from the TYPO3 v10.4.10 and everything works just fine.


Files

Actions #1

Updated by Oleg Karun about 3 years ago

A working example was here https://review.typo3.org/c/Packages/TYPO3.CMS/+/66760 but the problem apaired after that patch

Actions #2

Updated by Andreas Kienast about 3 years ago

  • Status changed from New to Rejected

Hello, thank you for your report.

This seems to be an issue with EXT:news. The markup of IRRE changed slightly and EXT:news XClasses some IRRE classes which miss the changed markup.
I'll report this to the EXT:news maintainer.

Kind regards
Andreas

Actions #3

Updated by Oleg Karun about 3 years ago

Oleg Karun wrote in #note-1:

A working example was here https://review.typo3.org/c/Packages/TYPO3.CMS/+/66760 but the problem apaired after that patch

Report was done the opposite way https://github.com/georgringer/news/issues/1410 link to issue

Actions

Also available in: Atom PDF