Bug #94105

Redirects not revertable by non admins

Added by Gerald Jelitto 3 months ago. Updated about 2 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend API
Target version:
-
Start date:
2021-05-10
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
10
PHP Version:
7.4
Tags:
redirect backend non-admin
Complexity:
Is Regression:
Sprint Focus:

Description

Non-admin users are not able to revert the redirect via the blue popup on page save, when the slug is changed and the page saved.

How to reproduce:
  • Create a page “test123” and save
  • Change page title to “test345", update the slug and save.
  • Redirect for keyword “test123” in Source Path should be visible in Redirect Module.
  • Click “Revert redirects only” in the blue popup
  • Redirect for keyword “test123” in Source Path should be gone in Redirect Module.

Repeat with any non-admin editor (make sure to grant access to redirect module, list rights for redirect show/edit, and allow all fields in the record itself)
The redirect will not be deleted in the last step.

Kind regards
Gerald


Related issues

Is duplicate of TYPO3 Core - Bug #91559: Reverting auto slug update for editors does not workUnder Review2020-06-03

Actions
#1

Updated by Guido Schmechel about 2 months ago

  • Is duplicate of Bug #91559: Reverting auto slug update for editors does not work added
#2

Updated by Riccardo De Contardi about 2 months ago

  • Status changed from New to Closed
  • Target version deleted (Candidate for patchlevel)

I close this issue as duplicate of #91559, please continue the discussion there; a relation between the two has been added; I've also added the description of this issue there to keep track of it.

Many thanks to Guido Schmechel for finding out the duplicate.

Also available in: Atom PDF