Bug #94885

Bug #94787: Tracking issue related to HTML sanitization issues

Bug #94776: Email Links with config.spamProtectEmailAddresses = 2 do not work after Update

Mailto Links missing href

Added by Thomas Rawiel 2 months ago. Updated 2 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2021-08-13
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
10
PHP Version:
7.4
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

After updating from 10.4.18 to 10.4.19 mailto links are not rendered properly via RTE ckeditor.

Typoscript is set:
config.spamProtectEmailAddresses = 1

No special RTE settings are configured, except for link classes and classesAnchor:

imports:
  - { resource: "EXT:rte_ckeditor/Configuration/RTE/Editor/Base.yaml" }
  - { resource: "EXT:rte_ckeditor/Configuration/RTE/Editor/Plugins.yaml" }
  - { resource: "EXT:rte_ckeditor_image/Configuration/RTE/Plugin.yaml" }

classes:
  link link--external:
    name: 'External Link'
  link link--internal:
    name: 'Internal Link'
  link link--file:
    name: 'File Link'
  link link--mail:
    name: 'Mailto Link'

buttons:
  link:
    page:
      properties:
        class:
          default: 'link link--internal'
    url:
      properties:
        class:
          default: 'link link--external'
    file:
      properties:
        class:
          default: 'link link--file'
    mail:
      properties:
        class:
          default: 'link link--mail'
    properties:
      class:
        allowedClasses:
          - 'link link--external'
          - 'link link--internal'
          - 'link link--file'
          - 'link link--mail'

classesAnchor:
  externalLink:
    class: 'link link--external'
    type: 'url'
    target: '_blank'
  internalLink:
    class: 'link link--internal'
    type: 'page'
  fileLink:
    class: 'link link--file'
    type: 'file'
    target: '_blank'
  mailLink:
    class: 'link link--mail'
    type: 'mail'

...

In the RTE the source code is

<p><a class="link link--mail" href="mailto:mail@example.com" title="Email me">mailtest</a></p>

It is rendered with the default fluid_styled_content Textmedia element:
<f:format.html>{data.bodytext}</f:format.html>

In the frontend the Tag is rendered as

<p><a title="Email me" class="link link--mail">mailtest</a></p>

Rolling back to 10.4.18 and flushing the cache, the following is rendered in the frontend:

<p><a href="javascript:linkTo_UnCryptMailto(%27nbjmup%2Bu%5C%2FsbxjfmAmjohofs%5C%2Fdpn%27);" title="Email me" class="link link--mail">mailtest</a></p>

which is the expected output.

Observation:
When composer updating, the following packages are installed:
- Installing masterminds/html5 (2.7.5): Extracting archive
- Installing typo3/html-sanitizer (v2.0.8): Extracting archive
- Upgrading typo3/cms-core (v10.4.18 => v10.4.19): Extracting archive
....
Maybe those new packages are involved

#1

Updated by Thomas Rawiel 2 months ago

  • Project changed from forge.typo3.org to TYPO3 Core
  • TYPO3 Version set to 10
  • PHP Version set to 7.4
#2

Updated by Oliver Hader 2 months ago

  • Parent task set to #94776
#3

Updated by Oliver Hader 2 months ago

  • Status changed from New to Closed

This is a duplicate of #94776 and has been fixed.

Also available in: Atom PDF