Bug #94919

PHP Warning: Invalid argument supplied for foreach() in /sysext/core/Classes/DataHandling/SoftReference/UrlSoftReferenceParser.php line 32

Added by Daniel Siepmann 4 months ago. Updated 4 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
Start date:
2021-08-18
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
11
PHP Version:
7.4
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

There is a warning in current master due to $parts being false instead of an array.
Accordingly, to preg_split docs, that means there was an actual error, not that it didn't match. So an easy type cast might be wrong here. Instead we should find the cause of the error.

The issue is caused by ./vendor/bin/typo3 referenceindex:update with following content:

<p>Nice to have:</p>
<ol>    <li>Add further tests</li>      <li>Check out <a href="{softref:5ab0deeea5faa1691e4d2b36b61a6105}">https://github.com/benjaminkott/syntax</a> and add proper syntax highlighting with defined code language to CKEditor. Just keep rendering via Server.<br />      pre tag parsing, add language, e.g. as attribute in RTE, extract and use it as config</li>      <li>Add <s>link list to</s>
YouTube videos somewhere (new page)<br />       https://www.youtube.com/playlist?list=PLDXiDr43HScExqOdpcQbCTmxfdBtIn63O<br />  Add as blog posts with categories?</li>         <li>Add page with projects<br />    /projects/sublime-text/fluid-snippets/</li>     <li>Proper TYPO3 cache handling<br />   <a href="{softref:bca09d3af089eabda3a6232ba21f72c2}">https://forge.typo3.org/issues/63821?issue_count=1&amp;issue_position=1</a></li>       <li>Add own link type "Twitter user"</li>       <li>Colors for code highlighting (Improve span amount and recognition)<br />    Add TypoScript</li>
<li>no bootstrap (issue with pre and with)</li>         <li>Add light mode support (css): <a href="{softref:217011bfd99088a721fbb8aa06ef54df}">https://developer.mozilla.org/en-US/docs/Web/CSS/@media/prefers-color-scheme</a></li> </ol>

And it looks like the issue was introduced in one of these commits: https://github.com/TYPO3-CMS/core/compare/293fa45605a994be4e83a6a509046a18e9582c44...7909d6d3109d0b7c5caaaf7a80c61ca20ba6c4b7, most probably: https://github.com/TYPO3-CMS/core/commit/608498f7c02550b0c37888ce43a76cd72d5198a0.

But I can't find a difference in the code.


Related issues

Related to TYPO3 Core - Bug #94920: "Register SoftReference parsers via DI breaks" breaks backendClosed2021-08-18

Actions
#1

Updated by Daniel Siepmann 4 months ago

  • Description updated (diff)
#2

Updated by Daniel Siepmann 4 months ago

  • Description updated (diff)
#3

Updated by Daniel Siepmann 4 months ago

  • Description updated (diff)
#4

Updated by Daniel Siepmann 4 months ago

  • Description updated (diff)
  • Status changed from In Progress to New
  • Assignee deleted (Daniel Siepmann)
#5

Updated by Simon Gilli 4 months ago

  • Related to Bug #94920: "Register SoftReference parsers via DI breaks" breaks backend added
#6

Updated by Simon Gilli 4 months ago

  • Status changed from New to Closed

Closing in favour of 94920.

Also available in: Atom PDF