Bug #94920

"Register SoftReference parsers via DI breaks" breaks backend

Added by Frank Naegler 2 months ago. Updated about 2 months ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
RTE (rtehtmlarea + ckeditor)
Target version:
Start date:
2021-08-18
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
11
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Since this change was merged:

https://review.typo3.org/c/Packages/TYPO3.CMS/+/70177

Save content elements in the backend is broken in case the text contains plain links like https://typo3.com

An example from our site:

<p>Data transmission to the US is based on the Standard Contractual Clauses (SCC) of&nbsp; the European Commission. Details can be found here:&nbsp;<br /> https://policies.google.com/privacy/frameworks and<br /> https://privacy.google.com/businesses/controllerterms/mccs/.</p>

Because the preg_split could return false but no guard clause exists, the following exception is thrown:

PHP Warning: Invalid argument supplied for foreach() in /../public/typo3/sysext/core/Classes/DataHandling/SoftReference/UrlSoftReferenceParser.php line 32


Related issues

Related to TYPO3 Core - Task #94687: Deprecate SoftReferenceIndexClosed2021-08-02

Actions
Related to TYPO3 Core - Feature #94741: Register SoftReference parsers via DIClosed2021-08-07

Actions
Related to TYPO3 Core - Bug #94919: PHP Warning: Invalid argument supplied for foreach() in /sysext/core/Classes/DataHandling/SoftReference/UrlSoftReferenceParser.php line 32Closed2021-08-18

Actions
#1

Updated by Frank Naegler 2 months ago

  • Related to Task #94687: Deprecate SoftReferenceIndex added
#2

Updated by Frank Naegler 2 months ago

  • Related to Feature #94741: Register SoftReference parsers via DI added
#3

Updated by Gerrit Code Review 2 months ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/70676

#4

Updated by Simon Gilli 2 months ago

  • Related to Bug #94919: PHP Warning: Invalid argument supplied for foreach() in /sysext/core/Classes/DataHandling/SoftReference/UrlSoftReferenceParser.php line 32 added
#5

Updated by Nikita Hovratov 2 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#6

Updated by Benni Mack about 2 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF