Bug #95880

Fix "undefined array key" warnings in HtmlParser with PHP 8

Added by Andreas Fernandez 8 months ago. Updated 8 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2021-11-05
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
11
PHP Version:
8.0
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Tested with Bootstrap Package, opening the page /content-examples/text/rich-text in the frontend:

(1/1) #1476107295 TYPO3\CMS\Core\Error\Exception
PHP Warning: Undefined array key "fixAttrib" in /var/www/html/typo3_src/typo3/sysext/core/Classes/Html/HtmlParser.php line 916

Related issues

Is duplicate of TYPO3 Core - Task #95738: Make HtmlParser compatible with PHP 8Resolved2021-10-23

Actions
#1

Updated by Gerrit Code Review 8 months ago

  • Status changed from In Progress to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/72059

#2

Updated by Andreas Fernandez 8 months ago

  • Is duplicate of Task #95738: Make HtmlParser compatible with PHP 8 added
#3

Updated by Andreas Fernandez 8 months ago

  • Status changed from Under Review to Closed

Also available in: Atom PDF