Bug #96350

PHP Warning: Undefined array key "content" in typo3/sysext/core/Classes/TimeTracker/TimeTracker.php line 539

Added by Florian Rival 8 months ago. Updated 8 months ago.

Status:
Resolved
Priority:
Should have
Assignee:
-
Category:
Form Framework
Target version:
Start date:
2021-12-14
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
11
PHP Version:
8.0
Tags:
Complexity:
easy
Is Regression:
Yes
Sprint Focus:

Description

How to reproduce :
  • set up a form
  • try to send a mail with that form in FE

This is because in PHP V8, a number of warnings have been converted into Error exceptions and especially : Attempting to read an undefined array key.

Have a look here : [[https://www.php.net/manual/fr/migration80.incompatible.php]]

#1

Updated by Gerrit Code Review 8 months ago

  • Status changed from New to Under Review

Patch set 1 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/72654

#2

Updated by Gerrit Code Review 8 months ago

Patch set 1 for branch 11.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/72676

#3

Updated by Florian Rival 8 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF