Project

General

Profile

Actions

Bug #98107

closed

Login to backend fails due to not renderable email message (i.e. mail notification when user logs in)

Added by Tobias Wegener almost 2 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend User Interface
Target version:
-
Start date:
2022-08-09
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
11
PHP Version:
7.4
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

I just noticed a super annoying and stupid bug while performing a major upgrade from v10 to v11:
I could not login successfully anymore to the backend due to a crazy reason.
I configured my TYPO3 installation to always send me a notification mail whenever someone tries to log into the backend (i.e. setting a valid email address in the field [BE][warning_email_addr] and setting [BE][warning_mode] to 1).
Simultaneously, I configured a login logo for the backend to refer to an image which resides somewhere under fileadmin (backend extension -> login.loginLogo).

With this configuration, the backend login will now always fail due to the exception #1630089406 which is thrown when the notification mail is being rendered. The exception message states 'Resource paths must start with "EXT:"'.
Very funny :-/ - when configuring the backend extension to use the logo it states:
'If set, this logo will be used instead of the TYPO3 logo above the login credential fields (e.g. fileadmin/images/login-logo.png or EXT:my_theme/Resources/Public/Images/login-logo.png or //domain.tld/login-logo.png).'

Obvisouly, one cannot use a logo which resides under fileadmin anymore for the backend login page.


Related issues 1 (1 open0 closed)

Is duplicate of TYPO3 Core - Bug #97733: Test mail setup fails with resources from fileadminUnder Review2022-06-05

Actions
Actions #1

Updated by Česlav Przywara almost 2 years ago

  • Is duplicate of Bug #97733: Test mail setup fails with resources from fileadmin added
Actions #2

Updated by Česlav Przywara almost 2 years ago

Seems to be the same issue as https://forge.typo3.org/issues/97733.

Actions #3

Updated by Riccardo De Contardi over 1 year ago

  • Status changed from New to Closed

I close this issue as a duplicate of #97733 - please continue the discussion there and test the attached patch.

If you think that this is the wrong decision, please reopen it or ping me and I'll do.

Thank you

Actions

Also available in: Atom PDF