Bug #86616

Updated by Chris Müller 9 months ago

I have multiple languages configured as single-tree. Now I created a 404 page in the page tree and referenced it in the Site Management module. I expected to see the content of the 404 page also with the status code 404 Not Found.

But I encountered the following issues:

* Calling /should-not-be-found: I got a redirect to the URL of the default deafult language (/en)
* Calling /should-not-be-found/level2: The same
* Calling /en/should-not-be-found: The status code is a 404 Not Found, but the content of the page is empty, the content-length header is set to 0. (it was fixed already in an update, in 9.5.4 this case works correctly)

My site configuration (config.yaml):

<pre><code class="yaml">
rootPageId: 3
base: 'https://www.example.net/'
baseVariants:
-
base: 'http://example.ddev.local:8080/'
condition: 'applicationContext == "Development"'
-
base: 'https://staging.example.net/'
condition: 'applicationContext == "Production/Staging"'
-
base: 'http://testing.example.net/'
condition: 'applicationContext == "Testing"'
languages:
-
title: English
enabled: true
languageId: '0'
base: /en
typo3Language: default
locale: en_US.utf8
iso-639-1: en
navigationTitle: English
hreflang: en
flag: us
-
title: Deutsch
enabled: true
languageId: '1'
base: /de
typo3Language: de
locale: de_DE.utf-8
iso-639-1: de
navigationTitle: Deutsch
hreflang: de
fallbackType: strict
flag: de
errorHandling:
-
errorCode: '404'
errorHandler: Page
errorContentSource: 't3://page?uid=96'
routes:
-
route: sitemap.xml
type: uri
source: 't3://page?uid=3&type=1533906435'
</code></pre>

The page 96 is set as visible, also both translations. I encounter this problem on my local ddev container (nginx), also on a webserver with Apache.

Back