Feature #103072

Updated by Mathias Brodala 3 months ago

Currently the TCA of TYPO3 knows these @ctrl@ options to enable and manage translation behavior for tables: 

 - @languageField@ (@sys_language_uid@ by convention) 
 - @transOrigPointerField@ (@l10n_parent@ by convention, @l18n_parent@ in @tt_content@) 
 - @translationSource@(@l10n_source@ by convention) @translationSource@ 
 - @transOrigDiffSourceField@ (@l10n_diffsource@ by convention, @l18n_diffsource@ in @tt_content@) 

 Each of these have 2 purposes: 

 1. Enable translations or a related feature 
 2. Tell TYPO3 which DB field to use in queries 

 This by itself is a problem but the main question is whether the names of these DB fields need to be configurable at all. 

 There are recently a lot of consolidations and simplifications in TCA. The same could be applied here: 

 - Turn these options from @string@ to @bool@, thus only enable/disable the feature. TYPO3 would then use fixed DB field names and thus fully manage these. 
 - Consolidate/merge these options with better and clearer names, e.g. @'enableTranslations' => true@, @'trackTranslationDifferences' => true@ or similar.