Project

General

Profile

Actions

Bug #102443

closed

Missing autoload class mapping if extension is import from TER

Added by Mike Zimmer 7 months ago. Updated 5 days ago.

Status:
Resolved
Priority:
Should have
Assignee:
-
Category:
Extension Manager
Target version:
-
Start date:
2023-11-22
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
11
PHP Version:
8.0
Tags:
Complexity:
easy
Is Regression:
Sprint Focus:

Description

If I download and install an extension via the Extension Manager in the backend of TYPO3, the autoload psr-4 information from ext_emconf.php is not processed.

My config where DeepL Namespace is missing in autoload files:

'autoload' => [
        'psr-4' => [
            'ThieleUndKlose\\Autotranslate\\' => 'Classes/',
            'DeepL\\' => 'Resources/Private/Deeplcom/DeeplPhp/src/',
        ],
],

Actions #1

Updated by Mike Zimmer 7 months ago

  • Subject changed from Missing autoload class mapping to Missing autoload class mapping if extension is import from TER
Actions #2

Updated by Tim Weisenberger 7 months ago

The bug is caused by the missing support for autoload configuration in EXTCONF serialization step while publishing a new version to TER. After the bug fix has been approved and deployed to the TER, a release of a new extension version to the TER is need to resolve this bug.

https://git.typo3.org/services/t3o-sites/extensions.typo3.org/ter/-/merge_requests/758

Actions #3

Updated by Georg Ringer 5 days ago

  • Status changed from New to Resolved

the linked issue has been merged, therefore closing this one

Actions

Also available in: Atom PDF