Project

General

Profile

Actions

Bug #102585

closed

Workspace preview link generated by PageTree "show" button contains "&" character

Added by Riccardo De Contardi 3 months ago. Updated 2 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Workspaces
Target version:
-
Start date:
2023-12-02
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
12
PHP Version:
8.1
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Prerequisites

  • TYPO3 12 (I tested it on 12.4.8)
  • An additional "Draft" workspace beside the usual "LIVE" workspace

Steps to reproduce

  • Go to the "Draft" workspace
  • Go to a page (any page) > page module
  • If you use the "preview" page button on the header, it opens the url:
https://yoursite.com/typo3/workspace/preview-control/?token=<SOME_TOKEN>&id=<ID_OF_THE_PAGE>

BUT if you instead use the context menu of the pagetree (left click> show) the url is

https://yoursite.com/typo3/workspace/preview-control/?token=<SOME_TOKEN>&amp;id=<ID_OF_THE_PAGE>

with
 &amp; 

instead of
&

There should not be difference; on my Ddev installation both links work the same but I've been reported that it could lead to an error like "503 (The link to the page with ID "0" could not be generated: No site found in root line of page 0)"

The issue seems not to affect TYPO3 v.11 or v.13, just v.12


Related issues 2 (0 open2 closed)

Related to TYPO3 Core - Bug #102441: Paste clipboard content - Text in flash message escapedResolved2023-11-22

Actions
Related to TYPO3 Core - Bug #102458: Copy/Cut of a page with single and double quotes in page title leads to escaped textResolved2023-11-22

Actions
Actions #1

Updated by Oliver Hader 3 months ago

  • Related to Bug #102441: Paste clipboard content - Text in flash message escaped added
Actions #2

Updated by Oliver Hader 3 months ago

  • Related to Bug #102458: Copy/Cut of a page with single and double quotes in page title leads to escaped text added
Actions #3

Updated by Oliver Hader 3 months ago

  • Status changed from New to Needs Feedback

Most probably this has been fixed with https://review.typo3.org/c/Packages/TYPO3.CMS/+/81865 in TYPO3 v12-dev, will be released with v12.4.9.

Could you please test again with the recent v12 dev branch?

Actions #4

Updated by Riccardo De Contardi 2 months ago

  • Status changed from Needs Feedback to Closed

I can confirm that the issue is fixed on 12.4.9

Thank you and sorry for my late reply. Closing it.

Actions

Also available in: Atom PDF